Article

Unable to start database after crash: (43) ** Cannot find or open file, errno = 32.

« Go Back

Information

 
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: Windows
Other: ODBC DataServer
Question/Problem Description
Unable to start database after crash: (43)    ** Cannot find or open file, errno = 32.
Database crashed after client connects to a second database with write failure errors 9450, 3645
Restart of database fails with error 43.
Cannot find or open file <file-name>, errno = 32. (43)
errno =32: The process cannot access the file because it is being used by another process.
Task manager shows many Progress processes still running.
Clarifying Information
The second database is a Schema holder for the ODBC DataServer:
The application connects to a remote database via the schema holder. 
The application connects via a DSN to an Access database then to a remote server DataSource (DSN) via linked tables using a second DSN. 
It is this second communication which fails. 
The Database log file repeats the Options message for the schema holder before the bkiowrite message and eventually abnormal shutdown:

(12699) Database <1st database> Options:
(12699) Database <2nd database> Options: which repeats many times followed by bkiowrite error 
(9450)  bkioWrite: Insufficient disk space during write, , fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. 
(3645)  bkwrite: write to disk failed errno 0.
(2249)  Begin ABNORMAL shutdown code 2
(334)   Multi-user session end.

The database crash did not disconnect all running Progress processes.
Although connection problems have happened in the past, this is the first time it resulted in a crash.
Client sessions use Georgia Software terminal emulator (aggressively holds onto terminal connections).
Client sessions use RF controller to connect from RF handhelds (aggressively holds on to RF connections).
Error MessagebkioWrite:Insufficient disk space during write, , fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9450)
bkwrite: write to disk failed errno <num>. (3645)
** Cannot find or open file <file-name>, errno = 32. (43)
Begin ABNORMAL shutdown code 2 (2249)
Defect/Enhancement Number
Cause
The errno with the error 43 indicates that Progress is being blocked from accessing files:

32 ERROR_SHARING_VIOLATION The process cannot access the file because it is being used by another process.

The database crash did not disconnect all processes and when the database tried to open the database extent it was still being held open by one of the processes left behind by the previous session.

 
Resolution
Reboot the server to clear all the Progress processes that are still connected to the database.

Examine the Windows Event Log to determine what caused the write failure during connection to the Schema Holder database in the first instance. On Windows Systems this is typically a non-Progress software accessing the database files at the same time causing a sharing violation.
Workaround
Notes
Attachment 
Feedback
 
Was this article helpful?

   

Your feedback is appreciated.

Please tell us how we can make this article more useful.



Characters Remaining: 255

 



Copyright © 1993-2014. Progress Software Corporation. All Rights Reserved. See the next generation of application development and data connectivity software, try now!