Article

How to unlock AppServer agents in LOCKED status after a network failure

Information

 
Article Number000060694
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: Windows
Question/Problem Description
How to unlock AppServer Agents in LOCKED status after a network failure?
Is there a way to unlock AppServer Agents in a LOCKED state after a network failure?
Steps to Reproduce
Clarifying Information
Error Message
Defect/Enhancement Number
Cause
Environment was experiencing network problems, more specifically network bandwidth bottleneck. Agents were stuck on LOCKED because it lost the connection to the AppServer client it was currently associated with.
Resolution
The AppServer KeepAlive (ASK) Protocol can be enabled on both the Server and client side if the configuration is not set up SSL:
  • non-SSL AppServer connections via a NameServer (AppServer protocol)
  • non-SSL AppServer direct connections (AppServerDC protocol)

1. To enable the ASK Protocol on the Server Side, modify the ubroker.properties file as follows:

[UBroker.AS]
serverASKActivityTimeout=<Time in Seconds to send the request to client>
serverASKResponseTimeout=<Time in Seconds to wait for response from client>
 
[UBroker.AS.<brokername>] 
appServerKeepaliveCapabilities=allowClientASK,allowServerASK 

2. Include the -AppServerKeepalive allowServerASK parameter to enable the ASK protocol on ABL/4GL client side:
hAppSrv:CONNECT ("-AppService <appservername> -H <host> -S <port/service name> -AppServerKeepalive allowServerASK").

Or do not include -AppServerKeepalive parameter because the default value is allowServerASK.
hAppSrv:CONNECT ("-AppService <appservername> -H <host> -S <port/service name> ).

Obs: The ASK protocol on the client is disabled by  adding  -AppServerKeepalive denyServerASK in the CONNECT method.
hAppSrv:CONNECT ("-AppService <appservername> -H <host> -S <port/service name> -AppServerKeepalive denyServerASK").





 
Workaround
Notes
Attachment 
Last Modified Date12/18/2018 4:34 PM


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