Article

Application process is crashing frequently

Information

 
Article Number000091371
EnvironmentProduct: OpenEdge
Version: 11.7.1
OS: AIX
Question/Problem Description
Application is crashing frequently.
There are errors in the OS log that coincides with the application process crash. 

Full stack trace from _progres -web(WebSpeed Agent) process on AIX reads:

uttraceback
uttrace_withsigid
utcoreEx
drexit
msgout
IPRA.$msgnGuts
vmsgn
msgn

 
Steps to Reproduce
Clarifying Information
Error MessageError writing to "<path/file name.lg>": No space left on device
Defect/Enhancement Number
Cause
Webspeed agent is trying to write to a file(stream) but the disk containing the file is full. 
 
Resolution
msgout is an C call where the OE process is trying to write to an stream. 
Make sure there is space on disk where the process is trying to write into. 
Workaround
Notes
Attachment 
Last Modified Date9/4/2018 3:39 PM


Feedback
 
Did this article resolve your question/issue?

   

Your feedback is appreciated.

Please tell us how we can make this article more useful. Please provide us a way to contact you, should we need clarification on the feedback provided or if you need further assistance.

Characters Remaining: 1025