Article

Database performance very slow on VMWare 6.7 after upgrade.

Information

 
Article Number000091547
EnvironmentProduct: Progress
Product: OpenEdge
Version: All supported versions
OS: All supported platforms
Question/Problem Description
Everything seems to be running slowly.
Users are hitting control-c to stop tasks.
Control-c causing 562 messages in logs.
DB logs have a lot of 562 hang up signal received messages.
Message 8534 client disconnected
Database restarted but performance did not improve.
Server rebooted but performance did not improve.
Can login up to 200 users, but no more.
Even Promon command hangs.
VMWare recently upgraded to version 6.7.
Steps to Reproduce
Clarifying Information
Error MessageHANGUP signal received. (562)
Client disconnected : . (8534)
Defect/Enhancement Number
Cause
The exact cause is not known at this time.

The Progress database version did not change.
There were changes to the hardware used.
There were changes to the iSCSI devices used. 
Resolution
The customer was referred to the hardware and virtualization vendor.

The hardware vendor added several more 10 gigabyte paths to the storage array.

The virtualization vendor increased the network maximum transmission unit (MTU) from 1500 to 9000.
The hardware vendor updated the firmware version of the storage array and the software version used to govern the storage array.

The virtualization vendor altered the write policy used to the storage array from "most recently used" to "round robin".


The iSCSI storage was re-configured to remove "delayed ack".
Workaround
Notes
Attachment 
Last Modified Date9/13/2018 3:07 PM


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