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Article

Error when attempting to access an OE Object from Rollbase

Information

 
Article Number000064053
EnvironmentProduct: Rollbase Private Cloud
Version: 3.2.4.0

Product: OpenEdge
Version: 11.4
Question/Problem Description
When attempting to access an OE Object from Rollbase we are receiving this error in the Rollbase UI (User Interface): Error: ERROR condition: The Server application has returned an error. (7243) (7211).
The OpenEdge AppServer also produces errors.
Steps to Reproduce
Clarifying Information
After changing OpenEdge Object authentication from "Use Current User" to "Basic Authentication", Rollbase started to throw the error: "Error: HTTP call failed: Unauthorized".
Error MessageRollbase UI:
Error: ERROR condition: The Server application has returned an error. (7243) (7211).
Error: HTTP call failed: Unauthorized

OpenEdg App Server log:
at line 1234 (mycustomprocedure.r)
<date and time> P-<number> T-<number> 1 AS -- --> mycustomprocedure.p
<date and time> P-<number> T-<number> 1 AS -- ** ABL Debug-Alert Stack Trace **
<date and time> P-<number> T-<number> 1 AS -- SECURITY-POLICY:SET-CLIENT failed because: the session registry is not loaded (15945)
Defect/Enhancement Number
Cause
The custom business entity does not support paging.
Resolution
Disabled the option "Service Object supports paging" in the OpenEdge Object.

Steps to disable the option:
  1. Navigate to Setup Home, Setup Application
  2. Click on the Object link
  3. Edit the OpeEdge Object and scroll down to reach out the OpenEdge Service properties
  4. Uncheck the option "Service Object supports paging".
  5. Save the object.
Workaround
Notes
Attachment 
Last Modified Date10/19/2015 2:25 PM