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Article

OpenEdge Explorer fails to reflect changes in ubroker.properties

Information

 
Article Number000081419
EnvironmentProduct: OpenEdge
Version: 11.3 and later
OS: Windows
Other: OpenEdge Explorer/Management
Question/Problem Description
OpenEdge Explorer fails to reflect changes in ubroker.properties

AdminServer's  warm start fails to update OpenEdge Explorer/Management object database.  
Steps to Reproduce
Clarifying Information
Error Message
Defect/Enhancement Number
Cause
The AdminServer's warm start process fails to update the OpenEdge Explorer's object database with the changes in the ubroker.properties file.
Resolution
To update the internal OpenEdge Explorer object database perform the following steps:

For Windows

1) From proenv stop the AdminServer using the command:

proadsv -stop

2) Make a backup of the OpenEdge Explorer object database using the command:

copy %OEM%\config\configdb\*.* C:\temp

3) Delete the OpenEdge Explorer object database using the command:

delete %OEM%\config\configdb\*.*

4) Start the AdminServer using the command:

proadsv -start

This last step will repopulate the OpenEdge Explorer object database.


 For UNIX

1) Run $DLC/bin/proenv

2) Stop the AdminServer using the command:

proadsv -stop

3) Make a backup of the OpenEdge Explorer object database using the command:

cp $OEM/config/configdb/*.* /tmp

4) Delete the OpenEdge Explorer object database using the command:

rm $OEM/config/configdb/*.*

5) Start the AdminServer using the command:

proadsv -start
Workaround
Notes
Attachment 
Last Modified Date6/18/2019 3:45 AM