000182560


OpenEdge processes sometimes hang or crash after receiving HANGUP or SIGUSR1
« Go Back
Information |
Title | OpenEdge processes sometimes hang or crash after receiving HANGUP or SIGUSR1 |
---|
URL Name | OpenEdge-processes-hang-or-crash-after-receiving-HANGUP-or-USR1-signal |
---|
Article Number | 000182560 |
---|
Environment | Product: OpenEdge
Version: 10.2B, 11.x OS: UNIX, Linux |
---|
Question/Problem Description |
|
---|
Steps to Reproduce | 1. Connect a client session and take note of the PID
$ _progress dbname -zp 2. Send SIGUSR1 signals from a looping batch process: example PID 14181 for (( i=1; i<=500 ; i++ )); do sudo /bin/kill -SIGUSR1 14181; sleep 5; done 3. After several minutes (approximately 10), the OpenEdge client session hangs, with no CPU activity. |
---|
Clarifying Information |
|
---|
Error Message |
---|
Defect Number | Defect PSC00347434 |
---|
Enhancement Number |
---|
Cause |
|
---|
Resolution![]() |
|
---|
Workaround |
|
---|
Notes |
---|
Last Modified Date | 11/25/2020 3:08 PM |
---|
Attachment |
---|
Files |
Disclaimer |
The origins of the information on this site may be internal or external to Progress Software Corporation (“Progress”). Progress Software Corporation makes all reasonable efforts to verify this information. However, the information provided is for your information only. Progress Software Corporation makes no explicit or implied claims to the validity of this information. Any sample code provided on this site is not supported under any Progress support program or service. The sample code is provided on an "AS IS" basis. Progress makes no warranties, express or implied, and disclaims all implied warranties including, without limitation, the implied warranties of merchantability or of fitness for a particular purpose. The entire risk arising out of the use or performance of the sample code is borne by the user. In no event shall Progress, its employees, or anyone else involved in the creation, production, or delivery of the code be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample code, even if Progress has been advised of the possibility of such damages. |