Feedback
 
Did this article resolve your question/issue?

   

Your feedback is appreciated.

Please tell us how we can make this article more useful. Please provide us a way to contact you, should we need clarification on the feedback provided or if you need further assistance.

Characters Remaining: 1025

 


Article

How to enable SSL for Webspeed and/or AppServer ?

« Go Back

Information

 
Article Number000010576
EnvironmentProduct: OpenEdge
Version: 10.x , 11.x
OS: All supported platforms
Question/Problem Description
How to enable SSL for Webspeed ?
How to enable SSL for AppServer ?
 
Steps to Reproduce
Clarifying Information
Error Message
Defect/Enhancement Number
Cause
Resolution

1) Create a private key and an associated certificate request:

proenv> pkiutil -newreq test

The PEM passphrase will be the private key password. You'll have to remember it.

2) Use %DLC%\keys\requests\test.pk10 to request a new digital certificate from a Certificate Authority (CA).

3) After you obtain the new digital certificate from the CA import the certificate into the keystore.

proenv> pkiutil -import test newcert.cer

4) Obtain and import the root CA certificate.

proenv> certutil -import <root>.pem

5) In ubroker.properties add the following entries:

[UBroker.WS.wsbroker1]
keyAlias=test
keyAliasPasswd=61607c736773646b6962
sslEnable=1

To get the keyAliasPasswd use genpassword:

proenv> genpassword -password 1234567890
61607c736773646b6962

The same entries are added in ubroker.properties for AppServer section. Alternatively use the OpenEdge Explorer or OpenEdge Management Console to configure the SSL properties.

Workaround
Notes
Attachment 
Last Modified Date9/4/2019 10:07 AM