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Article

Errors (10893), (11506) and (10899) when making a Web Service request after an AppServer shutdown

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Information

 
Article Number000010788
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: All supported platforms
Question/Problem Description
Errors (10893), (11506) and (10899) when making a Web Service request after an AppServer shutdown

The SOAP fault is generated only for the first Web Service request after the AppServer is restarted

This only occurs with the Session Free Model of Web Service

The following JAVA Exceptions appear in the WSA log file:

com.progress.ubroker.client.BrokerSystem$BrokerSystemCommunicationsException: Client Communications Failure - java.net.SocketException: Software caused connection abort: recv failed (8409)
Client Communications Failure - <Java Exception> (8409)
DISCONNECT IOException:  java.net.SocketException: Software caused connection abort: socket write error
com.progress.open4gl.Open4GLException: Disconnect failure: NULL.
Error in SOAP request execution: Communication layer message: Client Communications Failure - java.net.SocketException: Software caused connection abort: recv failed (8409). (7175) (10926)
Error in SOAP request execution: Communication layer message: Client Communications Failure - java.io.EOFException (8409). (7175) (10926)
Steps to Reproduce
Clarifying Information
Subsequent requests to the Web Service work just fine
Restarted the AppServer Broker that is being used by the Web Service
The AppServer Broker used by the Web Service has an Operating Mode of State-free
Error MessageWeb service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: An error was detected while executing the Web Service request. (10893) (11506)
An error was detected while executing the Web Service request. (10893)
Web service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: <fault-string> (11506)
A network error occurred executing the Web Service application. (10899)
Defect/Enhancement NumberEnhancement
Cause
It was determined that the Progress Product is functioning as designed.

If an error occurs while attempting to run a procedure on a session-free connection, the WSA cannot recover from the error by re-trying the request on another connection. This is because of the way that errors are detected when requests fail. If a request is run using a socket that has been disconnected by the remote node (e.g. the broker has been shut down and brought back up), no error is given when sending the request:  the client thinks that the request has been successfully sent. However, when the client attempts to receive the response, the exception is thrown. Given that errors are not detected when sending the request, the client cannot determine if the request was actually sent or not. This means that the request cannot be retried on another connection because this could cause the request to be run twice (if the first send didn't actually fail).
 
An enhancement to the product can be requested through the Progress Community via an Ideas submission.  Customer feedback is valuable and Idea submissions are monitored by our Product Management team.  Enhancement requests are reviewed during the planning phase of each new product release and a list of the enhancements chosen for implementation can be found in the Release Notes documents that accompany each release.  Once an Idea is submitted the Progress Software Community will have the opportunity to comment on and vote for the Idea.
 
For detailed information on how to submit an Idea, please refer to Knowledge Base article 000010839, How to submit an idea for a Progress product enhancement.
Resolution

Upgrade to 11.5 and move to the Pacific Application Server for OpenEdge.  The Pacific Application Server for OpenEdge (PASOE) is a platform that provides Web server support for Progress Applications including Rollbase, Corticon and OpenEdge.  PAS utilizes the industry-standard Tomcat server that is installed, configured and monitored as a Web Server.   This issue should not occur with PASOE because the server is treated as a single component.

If upgrading to 11.5 and switching to PASOE is not an option then restarting the AppServer Broker, and perform one of the following steps in order to avoid the broken communication between the WSA and the AppServer:

  • Re-enable the Web Service by issuing the following commands:

wsaman -name wsa1 -appname YourWebServiceName -disable
wsaman -name wsa1 -appname YourWebServiceName -enable

OR

  • Reload the WSA by shutting down and restarting the JSE (Tomcat, for instance).
OR
  • Send a test request to the Web Service to trigger the communication error. Then subsequent requests will not cause an issue.
Workaround
Notes
In some cases, trimming the AppServer agents is an alternative to shutting down the AppServer. In this case the connections from the WSA connection pool will be unaffected since they go through the AppServer broker.

When running the OpenEdge ESB adapter:

  • Reload the OpenEdge WebServices ESB container.

Example of command to execute from the ESB container console:

reload OEContainer

Network errors while executing Web services applications can occur for many reasons. If the steps above do not resolve the issue, further troubleshooting of the network and/or the Web services application may be required.

References to Other Documentation:
Progress Article(s):

000014610, After a couple of minutes the OpenEdge Web Service can no longer be accessed

Attachment 
Last Modified Date9/13/2015 3:06 AM