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Network idle timeouts prevent Web Service access for inactive sessions 10893, 11506 and 10899

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TitleNetwork idle timeouts prevent Web Service access for inactive sessions 10893, 11506 and 10899
URL NameP167205
Article Number000141033
EnvironmentProduct: OpenEdge
Version: OpenEdge 10.1x, 11.x
OS: All Supported Operating Systems
Other: Web Services Adapter, WSA
Question/Problem Description
After a couple of minutes the OpenEdge Web Service can no longer be accessed.
Errors 10893, 11506 and 10899 are returned when sending a Web Service request after some inactivity

 
Steps to Reproduce
Clarifying Information
The following are true:
  • There is a firewall between the WSA and the AppServer
  • The WSDL document is still accessible through the WSA
  • The SOAP fault is generated only for the first Web Service request after the inactivity
  • Subsequent requests to the Web Service work as expected
  • Only occurs with the Session Free Model of Web Service
  • The AppServer Broker used by the Web Service has an Operating Mode of State-free
  • The following JAVA Exceptions appear in the WSA log file:
com.progress.ubroker.client.BrokerSystem$BrokerSystemCommunicationsException:
Client Communications Failure - java.net.SocketException: Software caused connection abort: recv failed (8409)
 
DISCONNECT IOException:  java.net.SocketException:
Software caused connection abort: socket write error com.progress.open4gl.Open4GLException: Disconnect failure: NULL.
Error in SOAP request execution: Communication layer message: Client Communications Failure - java.net.SocketException:
Software caused connection abort: recv failed (8409). (7175) (10926)
Error in SOAP request execution: Communication layer message:
Client Communications Failure - java.io.EOFException (8409). (7175) (10926)
Error MessageWeb service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: An error was detected while executing the Web Service request. (10893) (11506)

An error was detected while executing the Web Service request. (10893)

Web service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: <fault-string> (11506)

A network error occurred executing the Web Service application. (10899)
Defect Number
Enhancement Number
Cause
Firewall configured to close network connections that remain idle for a specified amount of time. The OpenEdge Web Service can no longer be accessed as the firewall timeout period will cause an AppServer connection identified by the Firewall logic to be an idle connection and dropped.
Resolution

Options to prevent the AppServer being disconnected by the Firewall Idle timeout:

1.   Disable or increase the firewall timeout and verify that the OS TCP/IP KeepAlive value is lower than the firewall timeout.
        
2.   Add the _proapsv process to the list of firewall exclusions to not timeout
        
3.  Generate Network activity between the WSA and AppServer.
         
One way of doing this is to configure the AppServer "appServerKeepaliveCapabilities" property with a value of "denyClientASK,allowServerASK".
By default the WSA "appServerKeepalive" property is already set to "denyClientASK,allowServerASK".
The KeepAlive messages will then generate the required network activity between the WSA and the AppServer.
        
4.  Audit any timeouts throughout the roundtrip.

For example, Timeouts may also exist in the JSE (Java Servlet Engine, eg Tomcat) not only in the operating system or hardware layer.  Refer to the manufacturer of the JSE being used for pertinent documentation on configuring timeouts.
Workaround
Notes
Last Modified Date10/15/2020 10:16 AM
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