Feedback
 
Did this article resolve your question/issue?

   

Your feedback is appreciated.

Please tell us how we can make this article more useful. Please provide us a way to contact you, should we need clarification on the feedback provided or if you need further assistance.

Characters Remaining: 1025

 


Article

Which versions of Progress are supported against what AIX platforms

« Go Back

Information

 
Article Number000019693
EnvironmentProduct: Progress
Version: 8.x, 9.1x
Product: OpenEdge
Version: 10.x, 11.x
OS: IBM AIX POWER
Question/Problem Description
Which versions of Progress are supported against what AIX platforms
Which versions of Progress 9.x are certified against AIX?
Which versions of Open Edge 10.x are certified against AIX?
Which versions of Open Edge 11.x are certified against AIX?
Is Progress 9 supported on IBM AIX 4.3.3?
Is Progress 8 certified on IBM AIX 5.1?
Is Progress 9 supported on IBM AIX 5.3?
Is OpenEdge 10 supported on IBM AIX 5.2?
Is OpenEdge 10 supported on IBM AIX 6.1?
Is OpenEdge 11 supported on IBM AIX 5.3?
What versions of OpenEdge are supported on IBM AIX 7.1?
Is there a native 64-bit AIX OpenEdge port?
Is Progress 9.1E supported on AIX 6.1?
Steps to Reproduce
Clarifying Information
Error Message
Defect/Enhancement Number
Cause
Resolution
The following contains a historic list of Progress OpenEdge AIX Certifications
  • OS level can be verified via "instfix -i | grep ML".
  • There was no native support for 64-bit AIX for Progress 9.x, OpenEdge 10.0A and previous versions.
  • Since OpenEdge 11.1, the JDK used to certify the product is embedded with every OpenEdge platform install media. In prior versions, Java has to be obtained from the vendor and installed prior to installing OpenEdge. At the time of writing supported IBM Java versions are available at: https://developer.ibm.com/javasdk/support/fixes/
  • Refer to the Product Availability Guide and Life Cycle for the current version updates. Specifically, the "OpenEdge Java Certification Policy" (Effective January 2018) Article 000021678, Where is the OpenEdge Product Availability and Life Cycle Guide?  
OpenEdge 12.0:
  • IBM AIX (POWER PC) 7.1 64-bit  java 1.8.0_181
  • IBM AIX (POWER PC) 7.2 64-bit  java 1.8.0_181

OpenEdge 11.7:
  • IBM AIX (POWER PC) 6.1 64-bit  java 1.8.0_sr3_fp10
  • IBM AIX (POWER PC) 7.1 64-bit  java 1.8.0_sr3_fp10
OpenEdge 11.6:
  • IBM AIX (POWER PC) 6.1 64-bit java 1.7.0_sr6
  • IBM AIX (POWER PC) 7.1 64-bit java 1.7.0_sr6
Java 8 Runtime is supported on all OpenEdge 11.6 supported platforms. Refer to Article 000064040, Java 8: Does OpenEdge Support Java8 Runtime for OE11.6?

OpenEdge 11.5: 
  • IBM AIX (POWER PC) 6.1 64-bit java 1.7.0_sr6
  • IBM AIX (POWER PC) 7.1 64-bit java 1.7.0_sr6
OpenEdge 11.4:
  • IBM AIX (POWER PC) 6.1 64-bit java 1.7.0_sr6
  • IBM AIX (POWER PC) 7.1 64-bit java 1.7.0_sr6

OpenEdge 11.3:
  • IBM AIX (POWER PC) 6.1 64-bit java 1.7.0_20110810_1208
  • IBM AIX (POWER PC) 7.1 64-bit java 1.7.0_20110810_1208
Java 1.7.0 is also certified for PDSOE

OpenEdge 11.2:
  • IBM AIX (POWER PC) 6.1 64-bit java 1.6.0_20071205_64, 1.7.0_20110810_1208
  • IBM AIX (POWER PC) 7.1 64-bit java 1.6.0_20071205_64, 1.7.0_20110810_1208
Java version "1.7.0" Java(TM) SE Runtime Environment (build pap6470sr6-20131015_01(SR6))
Java 1.7.0 is certified for OpenEdge 11.2 and higher with the exception of PDSOE

OpenEdge 11.1: 
  • IBM AIX (POWER PC) 6.1 64-bit java 1.6.0_20071205_64
Beginning with OpenEdge 11.1, the JDK uses to certify the product is embedded with every OpenEdge platform install media, including AIX. In previous versions IBM Java could not provided with OpenEdge install media​

OpenEdge 11.0: (Java not supplied)
  • IBM AIX (POWER PC) 5.3 64-bit java 1.6.0_20071205_64
AIX 5.3 was dropped for OE 11.1 and higher

OpenEdge 10.2B: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.3 TL-7 32-bit java 1.5
  • IBM AIX (POWER PC) 5L v5.3 TL-7 64-bit java 1.5
  • IBM AIX (POWER PC) 6.1 32-bit java 1.5
  • IBM AIX (POWER PC) 6.1 64-bit java 1.5
  • IBM AIX (POWER PC) 7.1 32-bit java 1.5
  • IBM AIX (POWER PC) 7.1 64-bit java 1.5
OpenEdge 10.2A: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.3 TL-7 32-bitjava 1.5
  • IBM AIX (POWER PC) 5L v5.3 TL-7 64-bit java 1.5
  • IBM AIX (POWER PC) 6.1 32-bit java 1.5
  • IBM AIX (POWER PC) 6.1 64-bit java 1.5
OpenEdge 10.1C: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.2 32-bit + maintenance update 9 java 1.5
  • IBM AIX (POWER PC) 5L v5.2 64-bit + maintenance update 9 java 1.5
  • IBM AIX (POWER PC) 5L v5.3 32-bit java 1.5
  • IBM AIX (POWER PC) 5L v5.3 64-bit java 1.5
  • IBM AIX (POWER PC) 6.1 32-bit java 1.5
  • IBM AIX (POWER PC) 6.1 64-bit java 1.5
OpenEdge 10.1B: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.2 32-bit + maintenance update 1 + patch IY43963 java 1.4.2
  • IBM AIX (POWER PC) 5L v5.2 64-bit + maintenance update 1 + patch IY43963 java 1.4.2
  • IBM AIX (POWER PC) 5L v5.3 32-bit java 1.4.2
  • IBM AIX (POWER PC) 5L v5.3 64-bit java 1.4.2
  • IBM AIX (POWER PC) 6.1 32-bit java 1.4.2 (10.1B03 recommended)
  • IBM AIX (POWER PC) 6.1 64-bit java 1.4.2 (10.1B03 recommended)
If using WebServices, then use IBM AIX (POWER PC) 5L v5.3.03 java 1.4.2

OpenEdge 10.1A: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.2 32-bit + maintenance update 1 + patch IY43963 java 1.4.2
  • IBM AIX (POWER PC) 5L v5.2 64-bit  + maintenance update 1 + patch IY43963 java 1.4.2
  • IBM AIX (POWER PC) 5L v5.3 32-bit java 1.4.2
  • IBM AIX (POWER PC) 5L v5.3 64-bit java 1.4.2
SQL Client and RDBMS Connectivity: OpenEdge 10.1A and above are forward/backward compatible

OpenEdge 10.0B: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.2 32-bit + maintenance update 1 + patch IY43963 java 1.4.1
  • IBM AIX (POWER PC) 5L v5.2 64-bit + maintenance update 1 + patch IY43963 java 1.4.1
  • IBM AIX (POWER PC) 5L v5.3 32-bit java 1.4.2
  • IBM AIX (POWER PC) 5L v5.3 64-bit java 1.4.2
OpenEdge 10.0A: (Java not supplied)
  • IBM AIX (POWER PC) 5L v5.2 32-bit + maintenance update 1 + patch IY43963 java 1.4.1
AIX 5 64-bit, port will not be certified against OpenEdge 10.0A

Progress 9.1E: (Java not supplied)
  • IBM AIX POWER 5L 5.1 32-bit with ML5 JVM 1.3.1 SR6 
  • IBM AIX 5L 5.2 32-bit with ML1 JVM 1.3.1 SR6  
  • IBM AIX 5L 5.3 32-bit with JVM 1.3.1 SR6
AIX 5 64-bit, port will not be certified against Progress 9.x

Progress 9.1D: (Java not supplied)
  • IBM AIX 4.3.3 32-bit MUP level 10 with Java 1.3.0 ptf 9a
  • IBM AIX POWER 5.1 32-bit with IBM patch 5.1.0.0-02 requires Progress 9.1D05 Service Pack or later. JVM 1.3.1
  • IBM AIX 5.2 32-bit with IBM patch 5.2.0.0 requires Progress 9.1D06 Service Pack or later.  JVM 1.3.1
AIX 5.3, will not be certified against Progress 9.1D, as 9.1D was at the "Retired" product phase in the Progress Product Life Cycle when this OS became commercially available.

Progress 9.1C:  (Java supplied)
  • AIX 4.3.3 32-bit MUP level 2 is minimum OS level which is certified
  • AIX POWER 5.1 32-bit with IBM patch 001 requires Progress Patch 9.1C04 or higher.
AIX 5.2, will not be certified against Progress 9.1C, as 9.1C was at the "Retired" product phase in the Progress Product Life Cycle when this OS became commercially available.

Progress 8.3E: 
  • IBM AIX 4.1.4, 4.2,4.3,4.3.3 32-bit  
  • IBM AIX Power 5.1 32-bit with IBM patch 001
AIX 5.2, will not be certified against Progress 8.3E, as 8.3E was at the "Retired" product phase in the Progress Product Life Cycle when this OS became commercially available.



 
Workaround
Notes
References to Other Documentation:
Progress Article(s):

000079507, Is OpenEdge 10.x or OpenEdge 11.x supported on AIX 7.2 ?  
000021678, Where is the OpenEdge Product Availability and Life Cycle Guide?
Attachment 
Last Modified Date6/5/2019 4:56 PM