Home

How to suppress warning messages (5407),(5408),(5409),(5410) from displaying on client screens. 

000021861
Product: Progress
Version: 9.1D08, 9.1D09 ,9.1E
Product: OpenEdge
Version: 10.x, 11.x
OS: All Supported Platforms
How to suppress warning messages (5407),(5408),(5409),(5410) from displaying on client screens. 
WARNING: -nb exceeded. Automatically increasing from <old value> to <new value>. (5407)
WARNING: -l exceeded. Automatically increasing from <old value> to <new value>. (5408)
WARNING: -mmax exceeded. Automatically increasing from <old value> to <new value>. (5409)
WARNING: -D limit exceeded. Auto incrementing to <new value>. (5410)
Can the warning message (5407) be suppressed?
What is does the -noincrwarn startup parameter do?
Since Progress 9.1D08, the client-session startup parameter -noincrwarn was introduced to suppress the warning messages (5407) to (5410), because these warning messages could not be suppressed using the 4GL statement: SESSION:SUPPRESS-WARNINGS = YES.

Since OpenEdge 10.0A and 10.0B and 10.0B01, the client-session startup parameter -noincrwarn  was removed from the product.  The ABL SESSION:SUPPRESS-WARNINGS statement was enhanced to suppress these four warning messages (5407),(5408),(5409),(5410):
SESSION:SUPPRESS-WARNINGS = YES

The execution of the  4GL statement: SESSION:SUPPRESS-WARNINGS = YES. suppresses all warning messages during the session. Since OpenEdge 10.0B02, 10.1A the client session startup parameter -noincrwarn  was reintroduced to allow the selective suppression of these four warning messages only: (5407),(5408),(5409),(5410).  

For 9.1D Webclient, -noincrwarn has to be added in the Startup Parameters section of the Webclient Assembler. Then redeploy the application with a new version.
Progress Article:

000028901, How to suppress Progress warning messages  
 
12/17/2018 9:11 AM