Feedback
Did this article resolve your question/issue?

   

Article

Pages cannot be published after installation

« Go Back

Information

 
TitlePages cannot be published after installation
URL NamePages-cannot-be-published-after-installation
Article Number000125697
EnvironmentProduct: Sitefinity
Version: 5.x, 6.x, 7.x, 8.x, 9.x, 10.x, 11.x
OS: All supported OS versions
Database: All supported Microsoft SQL Server versions
Question/Problem Description

Pages cannot be published after moving the project to another environment and setting the project on IIS. When trying to publish the page an error is thrown.

Steps to Reproduce
Clarifying Information
  • In Sitefinity version 6.3 or later, the workflow is no longer searching for an endpoint as workflows are enabled to run InProcess (instead of XAMLX WCF services)
Error MessageThere was no endpoint listening at http://mydomain.com/DefaultWorkflows/PagesApprovalWorkflow.xamlx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
Defect/Enhancement Number
Cause

There are several possible causes:

  1. For versions below 6.3: only HTTPS is being used on the environment, which will not work as older versions require HTTP for the services.
  2. The issue is caused if the WorkflowBaseUrl setting under Administration » Settings » Advanced » System » ServicePaths is not updated/incorrect after moving the project to the new environment and thus Sitefinity is not able to find the default workflows.
  3. The issue is caused if in the WorkflowConfig.config an entry is missing its serviceUrl attribute.
Resolution
  1. Enable both HTTP and HTTPS on the Sitefinity environment.
  2. Update the WorkflowBaseURL, which needs to be set to the domain of the website (for example: http://mydomain.com), so that Sitefinity can find the default workflow services.

    In order to fix the issue go to Adminstration » Settings » Advanced » System » ServicePaths and in the WorkflowBaseUrl field enter your domain. This setting must be applied to the domain name which is also used in IIS to bind the server IP to it. For example, if the domain is associated with the server IP 83.142.17.132, the bindings in IIS should be as follows:

    type:  http
    hostname: mydomain.com
    port: 80
    IP address: 83.142.17.132
  3. Update the WorkflowConfig.config file:
    1. Add serviceUrl="~/DefaultWorkflows/ApprovalWorkflow.xamlx" to the entry that is missing it
    2. Save the config file
    3. Restart the site    
Workaround
Notes
Last Modified Date6/7/2019 6:57 AM
Attachment 
Files
Disclaimer The origins of the information on this site may be internal or external to Progress Software Corporation (“Progress”). Progress Software Corporation makes all reasonable efforts to verify this information. However, the information provided is for your information only. Progress Software Corporation makes no explicit or implied claims to the validity of this information.

Any sample code provided on this site is not supported under any Progress support program or service. The sample code is provided on an "AS IS" basis. Progress makes no warranties, express or implied, and disclaims all implied warranties including, without limitation, the implied warranties of merchantability or of fitness for a particular purpose. The entire risk arising out of the use or performance of the sample code is borne by the user. In no event shall Progress, its employees, or anyone else involved in the creation, production, or delivery of the code be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample code, even if Progress has been advised of the possibility of such damages.