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Article

Telerik Platform is unable to access Rollbase Catalog when Rollbase uses self-signed certificate

Information

 
Article Number000064050
EnvironmentProduct: Rollbase Private Cloud
Version: 4.x
Browser: Google Chrome
Question/Problem Description
Telerik Platform is unable to access Rollbase Catalog when Rollbase uses self-signed certificate throwing the error: "Catalog is unavailable" and requesting to install Google Chome extension.
Steps to Reproduce
Clarifying Information
Steps used to access Rollbase JSDO catalog:
  1. Create a catalog for one object that is defined in Rollbase.
  2. Modify the jsdoSettings.js in Teletik Platform as indicated on the Readme.txt using the URL provided by the Rollbase catalog.
  3. Run the app in Telerik for Android mobile.
  4. Provide login info normally used in Rollbase
  5. Click Login and it gives the error message "The page app.icenium.com says: Error on login Service https://www.mydomain.com/rest/jsdo/ catalog is unavailable. "
  6. Click Accept.
  7. Telerik Platform suggests installing an extension for Google Chrome.
  8. Install such extension.
Additionally:
Modify shared.properties file and add the following direction 
RBMobile_CORS.Allow_origin.HOST = %.*platform\\.telerik\\.com$%
 
Error MessageBrowser Popup:
The page app.icenium.com says: Error on login Service https://www.mydomain.com/rest/jsdo/ catalog is unavailable.

Application Yellow Warning popup:
Troubleshooting Tips:
To troubleshoot this issue, check for request errors in the developer tools console.
If the issue is CORS-related, you can install the AppBuilder Helper for Chrome to enable CORS for this device simulator.
Defect/Enhancement Number
Cause
Self-signed certificates are invalid when not signed by CA Providers.
Resolution
Install an accredited SSL certificate issued by a valid CA Provider.
For detailed information on CORS, please refer to the notes section below.
Workaround
Notes
Attachment 
Last Modified Date10/19/2015 1:30 PM