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"The specified URL is not valid: ~/Sitefinity/Email Campaigns" error after upgrade

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Title"The specified URL is not valid: ~/Sitefinity/Email Campaigns" error after upgrade
URL NameThe-specified-URL-is-not-valid-Sitefinity-Email-Campaigns-error-after-upgrade
Article Number000185928
EnvironmentProduct: Sitefinity
Version: 7.3, 8.x, 9.x,10.x, 11.x, 12.x
OS: All supported OS versions
Database: All supported Microsoft SQL Server versions
Question/Problem Description

After an upgrade the Email Campaigns module under Administration -> Modules and Services is marked as Failed and when clicking on the Details link of the module the following error message is displayed: "The specified URL is not valid: ~/Sitefinity/Email Campaigns" as demonstrated in the screenshot below:

emailcampaigns_error

In addition to this the Email Campaigns module is missing under the Marketing node from the backend navigation after the upgrade:

Marketing EmailCampaigns

 

Steps to Reproduce
Clarifying Information
Error Message"The specified URL is not valid: ~/Sitefinity/Email Campaigns"
Defect/Enhancement Number
Cause
The issue is caused if the Email Campaigns module has not been upgraded properly.
Resolution

In order to resolve the issue perform the steps below:

1. Make sure that the Marketing node is present in the navigation in the backend
2. If it is not present, navigate to Administration -> Modules and Service and install the Analytics module from its Actions link.
3. If the Marketing node appears in the navigation you may uninstall the Analytics module again if you are not using it.

When upgrading to versions below Sitefinity 9.0:
1. Open the ~/App_Data/Sitefinity/Configuration/SystemConfig.config file
2. Find the entry for the Newsletters
3. Change the version attribute of the Newsletters module to a 2500 build as demonstrated in the text marked in green below (this will trigger the upgrade script after restarting the application):
 
<add version="8.0.2500.0" name="Newsletters" />
 
4. Change the build version of the SystemConfig.config file to 2500 as demonstrated in the text marked in green below and save the file:
 
<systemConfig xmlns:config="urn:telerik:sitefinity:configuration"xmlns:type="urn:telerik:sitefinity:configuration:type"config:version="8.0.5700.0" build="2500" previousBuild="2000">

5. Restart the application

When upgrading to versions including and above Sitefinity 9.0 (for version 10.x, 11.x, 12.x):
1. Change the versions of Newsletters and Sitefinity in the database table "sf_module_vrsn" to a previous version like that:

module_name version 
 Sitefinity 8.0.2500.0
 Newsletters 8.0.2500.0

use the SQL queries below for this
update sf_module_vrsn
set version = '8.0.2500.0'
where module_name  = 'Newsletters' 

update sf_module_vrsn
set version = '8.0.2500.0'
where module_name = 'Sitefinity'


2. Restart the application.


We highly recommend performing the above steps on a backup of your project (not directly on your live environment since your site might become unresponsive during the optimization process and some issues may occur during this process).

If the issue still persists:

1. Go to Administration > Modules & Services
2. Find the Email Campaigns module
3. Re-install the module from its Actions link (Deactivate -> Uninstall -> Install)
Workaround
Notes
This article uses upgrade to version 8.0 as an example.
Remember to use your proper version i.e. 7.3.5100.0 or 8.2.5100.0
Last Modified Date5/20/2019 11:06 AM
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