Article

User being challenged accessing the catalog.

Information

 
Article Number000091550
EnvironmentProduct: OpenEdge
Version: 11.5.1
OS: Windows
Other:
Question/Problem Description
User is being challenged (asked for a username and password) when attempting to access the catalog for the application.
 
Steps to Reproduce
Clarifying Information
Error Message
Defect/Enhancement Number
Cause
User was attempting to access the catalog using a URL as follows:

http://<host>:<port>/<Project>/static/<Project>.json

The correct URL for accessing the catalog for this application is as follows:

http://<host>:<port>/<Project>/static/Mobile/<Project>.json
Resolution
Ensure the correct URL is being used when attempting access the catalog for a project.

If access is available, look in the project for file web.xml. This describes the authentication mechanism in use. This is defined under contextConfigLocation. Find the file in use and open it, for example, appSecurity-form-local.xml. Find the intercept-url entry for the url for the catalog. As in this case, there was an entry for static/Mobile/*.json but not for static/*.json. For the application, this might help narrow down the correct URL to access.
Workaround
Notes
Attachment 
Last Modified Date9/13/2018 3:54 PM


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