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proadsv -start fails with Port 20931 is already in use

Information

 
Titleproadsv -start fails with Port 20931 is already in use
URL Nameproadsv-start-fails-with-Port-20931-is-already-in-use
Article Number000186556
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: Windows
Other: AdminServer
Question/Problem Description
Getting an error saying 'port 20931 already in use' when trying to start the AdminServer with proadsv command.

proadsv -q command responds with "Failed connecting to AdminServer. Verify it is running. (8546)"

proadsv -start command fails with 'port already in use' error.
Steps to Reproduce
Clarifying Information
Error MessagePort 20931 is already in use. Please specify an alternate port with the -port argument.
Defect/Enhancement Number
Cause
The exact cause is not known at this time.

It appears something has caused the AdminServer to shutdown, but the related java.exe processes are still running.
Resolution
Open Windows Task Manager and stop the two java.exe processes that are related to the AdminServer and OpenEdge Management/OpenEdge Explorer (OEM/OEE).

The two command lines for the two java processes related to the AdminServer and OEM/OEE look like the following:

C:\<DLC>\jre\bin\java -classpath C:\<DLC>\jdk\lib\tools.jar;C:\<DLC>\jjava\progress.jar ...
C:\<DLC>\jre\bin\java -classpath 
C:\<DLC>/java/progress.jar;C:\<DLC>/java/osmetrics ...

After ending those processes, the AdminServer should start successfully.

 
Workaround
Restart the machine.
Notes
Last Modified Date1/17/2019 9:38 PM
Attachment 
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