Article

Troubleshooting system error 126 with the ConnectXE for ODBC Salesforce driver

« Go Back

Information

 
Article Number000032614
EnvironmentProduct: ConnectXE for ODBC Salesforce driver
Version: 6.1 and higher
OS: Windows x86 and x64
Database: Salesforce
Application: ODBC Administrator
Question/Problem Description
When attempting to test connect using the ConnectXE for ODBC Salesforce driver, one of the errors below is returned.
Steps to Reproduce
Clarifying Information
Error MessageSpecified driver could not be loaded to due system error 126: The specified module could not be found. (DataDirect 6.1 Salesforce, C:\Program Files\Progress\DataDirect\Connect_for_ODBC_61\Drivers\IVSFRC25.dll).
or
Specified driver could not be loaded to due system error 126: The specified module could not be found. (DataDirect 6.1 Salesforce, C:\Program Files\Progress\DataDirect\Connect64_for_ODBC_61\Drivers\DDSFRC25.dll).
or
Cannot initialize the data source object of OLE DB provider MSDASQL for linked server SALESFORCE.
OLE DB Provider MSDASQL for linked server SALESFORCE returned message Specified driver could not be loaded due to system error 126 (DataDirect 6.1 Salesforce). (Microsoft SQL Server, Error: 7303)
Defect/Enhancement Number
Cause
There are several possible causes for this error:
  • The driver is not able to find the JVM library or the JVM library cannot find its dependencies.
  • The application was not restarted after the driver was installed so the application did not pick up the driver path.
  • The incorrect ODBC Data Source Administrator is used.  The ODBC Administrator being used for the test connect must match the bitness of the driver (32-bit or 64-bit)
  • When User Account Control is turned on, some areas of the file system and registry cannot be written, even by an administrator user.  It seems that the administrator user does not always have full administrative privileges.
Resolution
  • The driver is not able to find the JVM library or the JVM library cannot find its dependencies.
For the 32-bit Salesforce driver, make sure the paths to the 32-bit JVM are on the system path, for example, C:\Program Files (x86)\Java\jre6\bin;C:\Program Files (x86)\Java\jre6\bin\client;

For the 64-bit Salesforce driver, make sure the paths to the 64-bit JVM are on the system path, for example, C:\Program Files\Java\jre6\bin;C:\Program Files\Java\jre6\bin\client;

If using SQL Server linked server, set the path as mentioned above and then restart SQL Server to pick up the path.
For any other application, make sure to restart the application after installing the driver.
 

  • The incorrect ODBC Data Source Administrator is used.

Use the ODBC Administrator that matches the bitness (32-bit or 64-bit) of the driver.  The 32-bit version of the ODBC Data Source Administrator is found at C:\WINDOWS\SysWOW64\odbcad32.exe. The 64-bit ODBC Administrator is found at C:\Windows\System32\odbcad32.exe. If the 64-bit driver is installed and the 32-bit ODBC Data Source Administrator is used, the 64-bit drivers are seen, but the test connection will fail.

Note that if you open the ODBC Administrator from the product's program group, the correct ODBC Administrator will be opened.
 

  • If User Account Control is turned on (Applies to Windows Vista, Windows Server 2008, and Windows 7 at this time), reinstall Java and the Connect(64) for ODBC product with the correct permissions as follows:

  a. Uninstall Java and the Connect64 for ODBC product and remove any remaining files under C:\Program Files\Progress\DataDirect\Connect64_for_ODBC_70.
  b. Using Run As Administrator (right-click the executable and choose Run As Administrator), reinstall both products, Java first.
  c. Check to make sure sure the system path includes the required Java paths C:\Program Files\Java\jre6\jre\bin and C:\Program Files\Java\jre6\jre\bin\client (or C:\Program Files\Java\jre6\jre\bin\server).
  d. Restart the ODBC Administrator and retry the test connect.

Workaround
Notes
Attachment 
Last Modified Date4/14/2016 8:29 PM
Disclaimer

The origins of the information on this site may be internal or external to Progress Software Corporation (“Progress”). Progress Software Corporation makes all reasonable efforts to verify this information. However, the information provided is for your information only. Progress Software Corporation makes no explicit or implied claims to the validity of this information.

Any sample code provided on this site is not supported under any Progress support program or service. The sample code is provided on an "AS IS" basis. Progress makes no warranties, express or implied, and disclaims all implied warranties including, without limitation, the implied warranties of merchantability or of fitness for a particular purpose. The entire risk arising out of the use or performance of the sample code is borne by the user. In no event shall Progress, its employees, or anyone else involved in the creation, production, or delivery of the code be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample code, even if Progress has been advised of the possibility of such damages.



Feedback
 
Was this article helpful?

   

Your feedback is appreciated.

Please tell us how we can make this article more useful. Please provide us a way to contact you, should we need clarification on the feedback provided or if you need further assistance.

Characters Remaining: 1025